“Sometimes it is the people no one can imagine anything of who do the things no one can imagine.” ― Sir Alan Turing


ADS

ADS

Tuesday, March 28, 2017

URI 1017 - Fuel Spent || Solution in C / C++



Little John wants to calculate and show the amount of spent fuel liters on a trip, using a car that does 12 Km/L. For this, he would like you to help him through a simple program. To perform the calculation, you have to read spent time (in hours) and the same average speed (km/h). In this way, you can get distance and then, calculate how many liters would be needed. Show the value with three decimal places after the point.

Input

The input file contains two integers. The first one is the spent time in the trip (in hours). The second one is the average speed during the trip (in Km/h).

Output

Print how many liters would be needed to do this trip, with three digits after the decimal point.
Input SampleOutput Sample
10
85
70.833
2
92
15.333
22
67
122.833

SOURCE CODE

#include <stdio.h>

int main() {
  int x, y;
  double d, m;

  scanf("%d %d", & x, & y);

  d = y / 12.000;
  m = d * x;

  printf("%0.3lf\n", m);

  return 0;
}

No comments:

Post a Comment