Read an integer value, which is the duration in seconds of a certain event in a factory, and inform it expressed in hours:minutes:seconds.
Input
The input file contains an integer N.
Output
Print the read time in the input file (seconds) converted in hours:minutes:seconds like the following example.
Input Sample | Output Sample |
556 | 0:9:16 |
1 | 0:0:1 |
140153 | 38:55:53 |
SOURCE CODE
#include <stdio.h>
int main()
{
int t, h, m, s;
scanf("%d", & t);
h = t / 3600;
m = (t % 3600) / 60;
s = (t % 60);
printf("%d:%d:%d\n", h, m, s);
return 0;
}
No comments:
Post a Comment