“Sometimes it is the people no one can imagine anything of who do the things no one can imagine.” ― Sir Alan Turing


ADS

ADS

Tuesday, March 28, 2017

URI - 1037 Interval || Solution in C / C++


You must make a program that read a float-point number and print a message saying in which of following intervals the number belongs: [0,25] (25,50], (50,75], (75,100]. If the read number is less than zero or greather than 100, the program must print the message “Fora de intervalo” that means "Out of Interval".
The symbol '(' represents greather than. For example:
[0,25] indicates numbers between 0 and 25.0000, including both.
(25,50] indicates numbers greather than 25 (25.00001) up to 50.0000000.

Input

The input file contains a floating-point number.

Output

The output must be a message like following example.
Input SampleOutput Sample
25.01Intervalo (25,50]
25.00Intervalo [0,25]
100.00Intervalo (75,100]
-25.02Fora de intervalo

SOURCE CODE

#include <stdio.h>

int main()

{
  float n;
  scanf("%f", & n);

  if (n < 0 || n > 100) {
    printf("Fora de intervalo\n");
  } else {
    if (n >= 0 && n <= 25) {
      printf("Intervalo [0,25]\n");
    } else if (n > 25 && n <= 50) {
      printf("Intervalo (25,50]\n");
    } else if (n > 50 && n <= 75) {
      printf("Intervalo (50,75]\n");
    } else
      printf("Intervalo (75,100]\n");
  }

  return 0;
}

No comments:

Post a Comment